use strict;
my $str = '<op>example2</op>
<op>asdas</op>
<simp>example1</simp><op>example2</op><val>example2</val>
<op></op>
<simp>example1</simp><op></op><val>example2</val>
<simp>example1</simp><op>12342</op><val>example2</val>';
my $regex = qr/<op>[A-Za-z0-9]*\<\/op>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}