$re = '/<op>[A-Za-z0-9]*\<\/op>/m';
$str = '<op>example2</op>
<op>asdas</op>
<simp>example1</simp><op>example2</op><val>example2</val>
<op></op>
<simp>example1</simp><op></op><val>example2</val>
<simp>example1</simp><op>12342</op><val>example2</val>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);