const regex = /<op>[A-Za-z0-9]*\<\/op>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<op>[A-Za-z0-9]*\\<\\\/op>', 'gm')
const str = `<op>example2</op>
<op>asdas</op>
<simp>example1</simp><op>example2</op><val>example2</val>
<op></op>
<simp>example1</simp><op></op><val>example2</val>
<simp>example1</simp><op>12342</op><val>example2</val>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}