#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/([a-zA-Z0-9._-]+(\s?[a-zA-Z0-9._-]+|\/?))+$"
Local $sString = "// Valid" & @CRLF & _
"/media" & @CRLF & _
"/media/shows" & @CRLF & _
"/media/movies/" & @CRLF & _
"/my media/shows" & @CRLF & _
"/my own media/movies" & @CRLF & _
"" & @CRLF & _
"// Invalid" & @CRLF & _
"/ media/shows" & @CRLF & _
"/media /shows" & @CRLF & _
"/media/ shows" & @CRLF & _
"/media/shows /" & @CRLF & _
"/ media /shows" & @CRLF & _
"/ media /shows/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")