re = /^\/([a-zA-Z0-9._-]+(\s?[a-zA-Z0-9._-]+|\/?))+$/m
str = '// Valid
/media
/media/shows
/media/movies/
/my media/shows
/my own media/movies
// Invalid
/ media/shows
/media /shows
/media/ shows
/media/shows /
/ media /shows
/ media /shows/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end