using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/([a-zA-Z0-9._-]+(\s?[a-zA-Z0-9._-]+|\/?))+$";
string input = @"// Valid
/media
/media/shows
/media/movies/
/my media/shows
/my own media/movies
// Invalid
/ media/shows
/media /shows
/media/ shows
/media/shows /
/ media /shows
/ media /shows/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}