import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/([a-zA-Z0-9._-]+(\\s?[a-zA-Z0-9._-]+|\\/?))+$";
final String string = "// Valid\n"
+ "/media\n"
+ "/media/shows\n"
+ "/media/movies/\n"
+ "/my media/shows\n"
+ "/my own media/movies\n\n"
+ "// Invalid\n"
+ "/ media/shows\n"
+ "/media /shows\n"
+ "/media/ shows\n"
+ "/media/shows /\n"
+ "/ media /shows\n"
+ "/ media /shows/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}