# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)^(DE:|VIR RECU)\h*(.+)//gm;t' <<< "VIR RECU 998721687978
DE: Mrs PAUL SMITH
564"