using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^(DE:|VIR RECU)\h*(.+)";
string substitution = @"";
string input = @"VIR RECU 998721687978
DE: Mrs PAUL SMITH
564";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}