#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?m)^(DE:|VIR RECU)\h*(.+)"
Local $sString = "VIR RECU 998721687978" & @CRLF & _
"DE: Mrs PAUL SMITH" & @CRLF & _
"564"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)