re = /(?m)^(DE:|VIR RECU)\h*(.+)/m
str = 'VIR RECU 998721687978
DE: Mrs PAUL SMITH
564'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result