import Foundation
let pattern = #"(?m)^(DE:|VIR RECU)\h*(.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
VIR RECU 998721687978
DE: Mrs PAUL SMITH
564
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)