#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[(\d+)\]"
Local $sString = "<input type="text" id="soutcontracts-work_address_ar-0" class="form-control" name="SoutContracts[work_address][0]" value="какой то адрес">" & @CRLF & _
"<input type="text" id="soutcontracts-work_address_ar-0" class="form-control" name="SoutContracts[work_address][7]" value="какой то адрес">" & @CRLF & _
"<input type="text" id="soutcontracts-work_address_ar-0" class="form-control" name="SoutContracts[work_address][100]" value="какой то адрес">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")