use strict;
my $str = '<input type="text" id="soutcontracts-work_address_ar-0" class="form-control" name="SoutContracts[work_address][0]" value="какой то адрес">
<input type="text" id="soutcontracts-work_address_ar-0" class="form-control" name="SoutContracts[work_address][7]" value="какой то адрес">
<input type="text" id="soutcontracts-work_address_ar-0" class="form-control" name="SoutContracts[work_address][100]" value="какой то адрес">';
my $regex = qr/\[(\d+)\]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}