// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[(\d+)\]").unwrap();
let string = "<input type=\"text\" id=\"soutcontracts-work_address_ar-0\" class=\"form-control\" name=\"SoutContracts[work_address][0]\" value=\"какой то адрес\">
<input type=\"text\" id=\"soutcontracts-work_address_ar-0\" class=\"form-control\" name=\"SoutContracts[work_address][7]\" value=\"какой то адрес\">
<input type=\"text\" id=\"soutcontracts-work_address_ar-0\" class=\"form-control\" name=\"SoutContracts[work_address][100]\" value=\"какой то адрес\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}