re = /\[(\d+)\]/m
str = '<input type="text" id="soutcontracts-work_address_ar-0" class="form-control" name="SoutContracts[work_address][0]" value="какой то адрес">
<input type="text" id="soutcontracts-work_address_ar-0" class="form-control" name="SoutContracts[work_address][7]" value="какой то адрес">
<input type="text" id="soutcontracts-work_address_ar-0" class="form-control" name="SoutContracts[work_address][100]" value="какой то адрес">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end