package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[(\d+)\]`)
var str = `<input type="text" id="soutcontracts-work_address_ar-0" class="form-control" name="SoutContracts[work_address][0]" value="какой то адрес">
<input type="text" id="soutcontracts-work_address_ar-0" class="form-control" name="SoutContracts[work_address][7]" value="какой то адрес">
<input type="text" id="soutcontracts-work_address_ar-0" class="form-control" name="SoutContracts[work_address][100]" value="какой то адрес">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}