const regex = /({{.*?}})|(<noinclude>((.|\n)*?)<\/noinclude>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('({{.*?}})|(<noinclude>((.|\\n)*?)<\\\/noinclude>)', 'g')
const str = `<noinclude>sdfwrtg
{{draft}}
wertert
</noinclude>
# A
# B
# C
# red → rouge
# yellow → jaune
# green → vert [pos:adjective, ipa: /vɜːt/]
<noinclude>sdfwrtg
{{draft}}
wertert
</noinclude>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);