import re
regex = re.compile(r"({{.*?}})|(<noinclude>((.|\n)*?)<\/noinclude>)")
test_str = ("<noinclude>sdfwrtg\n"
" {{draft}} \n"
"wertert\n"
"</noinclude>\n"
"# A\n"
"# B\n"
"# C \n"
"# red → rouge\n"
"# yellow → jaune\n"
"# green → vert [pos:adjective, ipa: /vɜːt/]\n"
"<noinclude>sdfwrtg\n"
" {{draft}} \n"
"wertert\n"
"</noinclude>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)