$re = '/({{.*?}})|(<noinclude>((.|\n)*?)<\/noinclude>)/';
$str = '<noinclude>sdfwrtg
{{draft}}
wertert
</noinclude>
# A
# B
# C
# red → rouge
# yellow → jaune
# green → vert [pos:adjective, ipa: /vɜːt/]
<noinclude>sdfwrtg
{{draft}}
wertert
</noinclude>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;