// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"({{.*?}})|(<noinclude>((.|\n)*?)<\/noinclude>)").unwrap();
let string = "<noinclude>sdfwrtg
{{draft}}
wertert
</noinclude>
# A
# B
# C
# red → rouge
# yellow → jaune
# green → vert [pos:adjective, ipa: /vɜːt/]
<noinclude>sdfwrtg
{{draft}}
wertert
</noinclude>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}