use strict;
my $str = '<noinclude>sdfwrtg
{{draft}}
wertert
</noinclude>
# A
# B
# C
# red → rouge
# yellow → jaune
# green → vert [pos:adjective, ipa: /vɜːt/]
<noinclude>sdfwrtg
{{draft}}
wertert
</noinclude>';
my $regex = qr/({{.*?}})|(<noinclude>((.|\n)*?)<\/noinclude>)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";