using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{1,2}):(\d{1,2}):(\d{1,4})\s+(\d{1,2}):(\d{1,2})\s+-\s+(\w{2})";
string input = @"01:12:1999 12:12 - ss
1:1:1 1:2 - sd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}