// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{1,2}):(\d{1,2}):(\d{1,4})\s+(\d{1,2}):(\d{1,2})\s+-\s+(\w{2})").unwrap();
let string = "01:12:1999 12:12 - ss
1:1:1 1:2 - sd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}