package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{1,2}):(\d{1,2}):(\d{1,4})\s+(\d{1,2}):(\d{1,2})\s+-\s+(\w{2})`)
var str = `01:12:1999 12:12 - ss
1:1:1 1:2 - sd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}