const regex = /(\d{1,2}):(\d{1,2}):(\d{1,4})\s+(\d{1,2}):(\d{1,2})\s+-\s+(\w{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1,2}):(\\d{1,2}):(\\d{1,4})\\s+(\\d{1,2}):(\\d{1,2})\\s+-\\s+(\\w{2})', 'gm')
const str = `01:12:1999 12:12 - ss
1:1:1 1:2 - sd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}