re = /(\d{1,2}):(\d{1,2}):(\d{1,4})\s+(\d{1,2}):(\d{1,2})\s+-\s+(\w{2})/m
str = '01:12:1999 12:12 - ss
1:1:1 1:2 - sd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end