import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(0[1-9]|[12][0-9]|3[01]):(0[1-9]|1[012]):(\\d{1,4})\\s+([0-1][0-9]|2[0-3]):([0-5][0-9])\\s+-\\s+(\\w{2})";
final String string = "21:10:1999 12:12 - ss\n"
+ "01:10:1999 12:12 - ss\n"
+ "01:10:1999 23:59 - ss\n"
+ "01:10:1999 00:59 - ss\n"
+ "01:10:1999 00:61 - ss\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}