re = /(0[1-9]|[12][0-9]|3[01]):(0[1-9]|1[012]):(\d{1,4})\s+([0-1][0-9]|2[0-3]):([0-5][0-9])\s+-\s+(\w{2})/m
str = '21:10:1999 12:12 - ss
01:10:1999 12:12 - ss
01:10:1999 23:59 - ss
01:10:1999 00:59 - ss
01:10:1999 00:61 - ss
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end