const regex = /(0[1-9]|[12][0-9]|3[01]):(0[1-9]|1[012]):(\d{1,4})\s+([0-1][0-9]|2[0-3]):([0-5][0-9])\s+-\s+(\w{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(0[1-9]|[12][0-9]|3[01]):(0[1-9]|1[012]):(\\d{1,4})\\s+([0-1][0-9]|2[0-3]):([0-5][0-9])\\s+-\\s+(\\w{2})', 'gm')
const str = `21:10:1999 12:12 - ss
01:10:1999 12:12 - ss
01:10:1999 23:59 - ss
01:10:1999 00:59 - ss
01:10:1999 00:61 - ss
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}