use strict;
my $str = '21:10:1999 12:12 - ss
01:10:1999 12:12 - ss
01:10:1999 23:59 - ss
01:10:1999 00:59 - ss
01:10:1999 00:61 - ss
';
my $regex = qr/(0[1-9]|[12][0-9]|3[01]):(0[1-9]|1[012]):(\d{1,4})\s+([0-1][0-9]|2[0-3]):([0-5][0-9])\s+-\s+(\w{2})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}