const regex = new RegExp('DATA\\s+SCIENTIST', 'gm')
const str = `DATA ANALYTIC SCIENTIST
BEST DATA SCIENTIST
DATA SCIENTIST
DATA SCIENTIST
SCIENTIST DATA
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);