re = /DATA\s+SCIENTIST/m
str = 'DATA ANALYTIC SCIENTIST
BEST DATA SCIENTIST
DATA SCIENTIST
DATA SCIENTIST
SCIENTIST DATA
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result