#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d+\) )"
Local $sString = "1) Pergunta 1" & @CRLF & _
"2) Pergunta 2" & @CRLF & _
"3) Pergunta 3" & @CRLF & _
"4) Pergunta 4" & @CRLF & _
"10) Pergunta 10" & @CRLF & _
") Pergunta sem número"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")