$re = '/^(\d+\) )/m';
$str = '1) Pergunta 1
2) Pergunta 2
3) Pergunta 3
4) Pergunta 4
10) Pergunta 10
) Pergunta sem número';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);