// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d+\) )").unwrap();
let string = "1) Pergunta 1
2) Pergunta 2
3) Pergunta 3
4) Pergunta 4
10) Pergunta 10
) Pergunta sem número";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}