package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+\) )`)
var str = `1) Pergunta 1
2) Pergunta 2
3) Pergunta 3
4) Pergunta 4
10) Pergunta 10
) Pergunta sem número`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}