re = /^(\d+\) )/m
str = '1) Pergunta 1
2) Pergunta 2
3) Pergunta 3
4) Pergunta 4
10) Pergunta 10
) Pergunta sem número'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end