$re = '/^\d{5}\s{6}[\s\*](?:[^.:;()]*|(?<!\s)[.:;]|\((?!\s)|(?<!\s)\))*$/m';
$str = '00000 *TEST .FINAL STATEMENT.
00001 *TEST2 . FINAL STATEMENT.
00002 *TEST3. FINAL STATEMENT.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);