re = /^\d{5}\s{6}[\s\*](?:[^.:;()]*|(?<!\s)[.:;]|\((?!\s)|(?<!\s)\))*$/m
str = '00000 *TEST .FINAL STATEMENT.
00001 *TEST2 . FINAL STATEMENT.
00002 *TEST3. FINAL STATEMENT.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end