using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[, ])myTable(?=[^2])";
string substitution = @"myTable3";
string input = @"select myTable.x,myTable.y,myTable.myTable from myTable join myTable2 ON myTable.x = myTable2.x
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}