re = /(?<=[, ])myTable(?=[^2])/m
str = 'select myTable.x,myTable.y,myTable.myTable from myTable join myTable2 ON myTable.x = myTable2.x
'
subst = 'myTable3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result