import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[, ])myTable(?=[^2])";
final String string = "select myTable.x,myTable.y,myTable.myTable from myTable join myTable2 ON myTable.x = myTable2.x\n\n\n\n\n";
final String subst = "myTable3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}