import Foundation
let pattern = #"(?<=[, ])myTable(?=[^2])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
select myTable.x,myTable.y,myTable.myTable from myTable join myTable2 ON myTable.x = myTable2.x
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"myTable3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)