const regex = /"Reseller_Helpdesk_Number__c":"(?<reseller>.*?)"}]}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"Reseller_Helpdesk_Number__c":"(?<reseller>.*?)"}]}', 'gm')
const str = `{"searchRecords":[{"attributes":{"type":"Contact","url":"/services/data/v43.0/sobjects/Contact/003e000000wQySZAA0"},"Id":"003e000000wQySZAA0","Reseller_Helpdesk_Number__c":"Toast Supported"}]}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}