// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"Reseller_Helpdesk_Number__c":"(?<reseller>.*?)"}]}"#).unwrap();
let string = "{\"searchRecords\":[{\"attributes\":{\"type\":\"Contact\",\"url\":\"/services/data/v43.0/sobjects/Contact/003e000000wQySZAA0\"},\"Id\":\"003e000000wQySZAA0\",\"Reseller_Helpdesk_Number__c\":\"Toast Supported\"}]}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}