use strict;
my $str = '{"searchRecords":[{"attributes":{"type":"Contact","url":"/services/data/v43.0/sobjects/Contact/003e000000wQySZAA0"},"Id":"003e000000wQySZAA0","Reseller_Helpdesk_Number__c":"Toast Supported"}]}';
my $regex = qr/"Reseller_Helpdesk_Number__c":"(?<reseller>.*?)"}]}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}