$re = '/"Reseller_Helpdesk_Number__c":"(?<reseller>.*?)"}]}/m';
$str = '{"searchRecords":[{"attributes":{"type":"Contact","url":"/services/data/v43.0/sobjects/Contact/003e000000wQySZAA0"},"Id":"003e000000wQySZAA0","Reseller_Helpdesk_Number__c":"Toast Supported"}]}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);