import re
regex = re.compile(r"\"Reseller_Helpdesk_Number__c\":\"(?<reseller>.*?)\"}]}", flags=re.MULTILINE)
test_str = "{\"searchRecords\":[{\"attributes\":{\"type\":\"Contact\",\"url\":\"/services/data/v43.0/sobjects/Contact/003e000000wQySZAA0\"},\"Id\":\"003e000000wQySZAA0\",\"Reseller_Helpdesk_Number__c\":\"Toast Supported\"}]}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")