# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(([^,]*,){2})([^,]*,)(.*)$/\1\4/mg;t' <<< "1,2,3,4,5,6,7"